You can skip this in seconds

Click here to continue

jalada Comrade Stalin 1.5.0

Download Now!

This download will be managed by our ad-supported smart download manager. Learn more

What's Required in Version 1.5.0 of jalada Comrade Stalin

G4 1.5 GHz (or better) or Intel Mac.

What's New in Version 1.5.0 of jalada Comrade Stalin

This release features new AIs, improved maps and models as well as Snow Leopard compatibility updates.

Look for Similar Items by Category

Feedback

Popular Downloads